[KNOWLEDGE BASE] [ E-MAIL]

 PROBLEMS RETRIEVING E-MAILS WITH NORTON ANTIVIRUS INSTALLED 
 

PROBLEM

Unable to retrieve any POP3 e-mail with NAV (Norton Anti Virus) installed. You may get an error message saying something like, "The connection to the server has failed." The server is identified as either "127.0.0.1" or "pop3.norton.antivirus".

CAUSE

NAV positions itself between the POP3 mail server and the e-mail client making it a critical link. When it malfunctions it can halt e-mail delivery.

The tricky thing about e-mail scanning is that it has to take place in real-time. Once the e-mail shows up in your in-box it's too late in many cases to prevent damage by a malicious worm or attachment. The anti-virus software has to therefore intercept the e-mail message after it leaves the POP3 server at the ISP but before it gets to the PC's e-mail program. NAV does this by installing a virtual POP3 server on the PC. (N.B. NAV can't scan HTTP accounts like Hotmail). When NAV2000 is installed it creates this virtual server, giving it an address of 127.0.0.1 (a standard loopback IP address); NAV2001 calls it pop3.norton.antivirus. All incoming mail is then routed through this virtual server before being sent to your inbox.

If you press CTRL-ALT-DELETE you will see a program running called Popproxy. This is NAV's virtual server. The system will work fine as long as NAV's virtual POP3 server is open for business. If this process gets shut down, the virtual server will stop working and no mail will get forwarded to the e-mail client.

 

SOLUTIONS

Resetting the POP3 server address to the ISP's original POP3 address and disabling e-mail scanning in NAV should sort the problem out. HOWEVER, doing this will also disable any real-time e-mail virus checking by NAV.

Check to see if e-mail scanning has been enabled in NAV. If it has then press CTRL-ALT-DELETE to see if Popproxy is running.If it's not running then try rebooting the PC to see if this restores it.

If this still doesn't work then try double-clicking on Popproxy.exe in the c:\Program Files\ Norton Antivirus directory. This should relaunch the program.